import re
regex = re.compile(r"(?:\"|\G(?<!\")(?!\A))(?<r>[^a\"\\]*+(?>\\.[^a\"\\]*)*+)\K(a|\"(*SKIP)(*F))(?(?=((?&r)\"))\3)")
test_str = ("Problem: I have thousands of documents which contains a specific character I don't want. E.g. \"the character a\". These documents contain a variety of characters, but the a's I want to replace \"are inside double quotes or\" single quotes.\n\n"
"I would \"like to find and replace them\", and I thought using Regex would be needed. I am using VSCode, but I'm open to any suggestions.\n\n"
"My attempt: I was able to find the following regex to match for a specific string containing the \"values inside the\" ().\n\n"
"\".*?(r).*?\"\n"
"However, this only highlights the entire quote. I want to highlight the character only.\n\n"
"Any solution, \"perhaps outside of regex\", is welcome.")
subst = "***\\3"
result = regex.sub(subst, test_str)
if result:
print(result)