using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:""|\G(?<!"")(?!\A))(?<r>[^a""\\]*+(?>\\.[^a""\\]*)*+)\K(a|""(*SKIP)(*F))(?(?=((?&r)""))\3)";
string substitution = @"***\3";
string input = @"Problem: I have thousands of documents which contains a specific character I don't want. E.g. ""the character a"". These documents contain a variety of characters, but the a's I want to replace ""are inside double quotes or"" single quotes.
I would ""like to find and replace them"", and I thought using Regex would be needed. I am using VSCode, but I'm open to any suggestions.
My attempt: I was able to find the following regex to match for a specific string containing the ""values inside the"" ().
"".*?(r).*?""
However, this only highlights the entire quote. I want to highlight the character only.
Any solution, ""perhaps outside of regex"", is welcome.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}