import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.{41})[a-z0-9]+(?:\\.[a-z0-9]+)*@[a-z0-9-]+(?:\\.[a-z0-9-]+)*\\.[a-zA-Z]{2,6}$";
final String string = "emailid@domain.com\n"
+ "email.id@dom.ain.com\n"
+ "email.id@dom.a--in.com\n"
+ "email..id@dom.ain.com\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}