re = /^(?!.{41})[a-z0-9]+(?:\.[a-z0-9]+)*@[a-z0-9-]+(?:\.[a-z0-9-]+)*\.[a-zA-Z]{2,6}$/m
str = 'emailid@domain.com
email.id@dom.ain.com
email.id@dom.a--in.com
email..id@dom.ain.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end