const regex = /^(?!.{41})[a-z0-9]+(?:\.[a-z0-9]+)*@[a-z0-9-]+(?:\.[a-z0-9-]+)*\.[a-zA-Z]{2,6}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.{41})[a-z0-9]+(?:\\.[a-z0-9]+)*@[a-z0-9-]+(?:\\.[a-z0-9-]+)*\\.[a-zA-Z]{2,6}$', 'gm')
const str = `emailid@domain.com
email.id@dom.ain.com
email.id@dom.a--in.com
email..id@dom.ain.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}