# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b([0-9]+)\b/$1~09876543210/g;t' <<< "49"