$re = '/\b([0-9]+)\b/';
$str = '49';
$subst = "$1~09876543210";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;