import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[A-Z0-9]{2}(?:\\.[A-Z0-9]{2})*\\b|\\b([a-zA-Z])([a-zA-Z]*)\\b";
final String string = "abcd-efgh-ijkl 10.20.AB.20.CD\n"
+ "ACvrf";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}