// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b[A-Z0-9]{2}(?:\.[A-Z0-9]{2})*\b|\b([a-zA-Z])([a-zA-Z]*)\b").unwrap();
let string = "abcd-efgh-ijkl 10.20.AB.20.CD
ACvrf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}