$re = '/\b[A-Z0-9]{2}(?:\.[A-Z0-9]{2})*\b|\b([a-zA-Z])([a-zA-Z]*)\b/m';
$str = 'abcd-efgh-ijkl 10.20.AB.20.CD
ACvrf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);