package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[1-9](?:\d*[1-9])?\b`)
var str = `123 456 7890
010
0
1 1000001`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}