$re = '/\b[1-9](?:\d*[1-9])?\b/m';
$str = '123 456 7890
010
0
1 1000001';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);