const regex = /\b[1-9](?:\d*[1-9])?\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[1-9](?:\\d*[1-9])?\\b', 'gm')
const str = `123 456 7890
010
0
1 1000001`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}