re = /^(?'Year'(?:[2][0]|[1][9])(?:[0-9]{2,2}))(?'Month'(?:[0][1-9]|[1][0-2]))(?'Day'[0-2][1-9]|[3][0-1]|[1,2][0])$/
str = '20210112'
# Print the match result
str.match(re) do |match|
puts match.to_s
end