import Foundation
let pattern = #"^(?'Year'(?:[2][0]|[1][9])(?:[0-9]{2,2}))(?'Month'(?:[0][1-9]|[1][0-2]))(?'Day'[0-2][1-9]|[3][0-1]|[1,2][0])$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"20210112"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}