package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*[A-Za-z]+\s+[A-Za-z]+\s*$`)
var str = `Hello World
Hello World
test 123
testing for123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}