re = /^\s*[A-Za-z]+\s+[A-Za-z]+\s*$/m
str = 'Hello World
Hello World
test 123
testing for123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end