$re = '/^\s*[A-Za-z]+\s+[A-Za-z]+\s*$/m';
$str = 'Hello World
Hello World
test 123
testing for123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);