using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".* (\d{1,3})%.*";
string input = @"/dev/sda1 472437724 231650856 216764652 52% /";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}