package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).* (\d{1,3})%.*`)
var str = `/dev/sda1 472437724 231650856 216764652 52% /`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}