$re = '/.* (\d{1,3})%.*/m';
$str = '/dev/sda1 472437724 231650856 216764652 52% /';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);