#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\w+)\/?(.*?)\/?$"
Local $sString = "hqvg/action/apokd/" & @CRLF & _
"hqvg/action/apokd" & @CRLF & _
"hqvg/" & @CRLF & _
"hqvg" & @CRLF & _
"hqvg/action/apokd/azdada/adaZ/ada/da" & @CRLF & _
"hqvg/action/apokd/azdada/adaZ/ada/da/" & @CRLF & _
"azadadzadazdazdazd" & @CRLF & _
"/azdazdad/adazd" & @CRLF & _
"otherAppUid/anAction/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")