re = /^(\w+)\/?(.*?)\/?$/m
str = 'hqvg/action/apokd/
hqvg/action/apokd
hqvg/
hqvg
hqvg/action/apokd/azdada/adaZ/ada/da
hqvg/action/apokd/azdada/adaZ/ada/da/
azadadzadazdazdazd
/azdazdad/adazd
otherAppUid/anAction/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end