using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\w+)\/?(.*?)\/?$";
string input = @"hqvg/action/apokd/
hqvg/action/apokd
hqvg/
hqvg
hqvg/action/apokd/azdada/adaZ/ada/da
hqvg/action/apokd/azdada/adaZ/ada/da/
azadadzadazdazdazd
/azdazdad/adazd
otherAppUid/anAction/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}