#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!.*(?:this|and|that))(wp-(.*)|xmlrpc)\.php$"
Local $sString = "wp-this.php" & @CRLF & _
"wp-settings.php" & @CRLF & _
"wp-and.php" & @CRLF & _
"wp-config.php" & @CRLF & _
"that.php" & @CRLF & _
"xmlrpc.php" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")