import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!.*(?:this|and|that))(wp-(.*)|xmlrpc)\\.php$";
final String string = "wp-this.php\n"
+ "wp-settings.php\n"
+ "wp-and.php\n"
+ "wp-config.php\n"
+ "that.php\n"
+ "xmlrpc.php\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}