using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!.*(?:this|and|that))(wp-(.*)|xmlrpc)\.php$";
string input = @"wp-this.php
wp-settings.php
wp-and.php
wp-config.php
that.php
xmlrpc.php
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}