#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(((\+49\ ))|(0))\d{3,4}\ (\d{7}|\d{6}(\-\d{2})?)"
Local $sString = "// valid" & @CRLF & _
"//Landline" & @CRLF & _
"0221 999985" & @CRLF & _
"0221 999985-80" & @CRLF & _
"// Mobile" & @CRLF & _
"01578 1234567" & @CRLF & _
"// International" & @CRLF & _
"+49 221 999985" & @CRLF & _
"+49 221 999985-60" & @CRLF & _
"+49 1578 1234567" & @CRLF & _
"" & @CRLF & _
"// invalid" & @CRLF & _
"(06442) 3933023" & @CRLF & _
"(02852) 5996-0" & @CRLF & _
"(042) 1818 87 9919" & @CRLF & _
"06442 / 3893023" & @CRLF & _
"06442 / 38 93 02 3" & @CRLF & _
"06442/3839023" & @CRLF & _
"042/ 88 17 890 0" & @CRLF & _
"+49 221 549144 – 79" & @CRLF & _
"+49 221 - 542194 79" & @CRLF & _
"+49 (221) - 542944 79" & @CRLF & _
"0 52 22 - 9 50 93 10" & @CRLF & _
"+49(0)121-79536 - 77" & @CRLF & _
"+49(0)2221-39938-113" & @CRLF & _
"+49 (0) 1739 906-44" & @CRLF & _
"+49 (173) 1799 806-44" & @CRLF & _
"0173173990644" & @CRLF & _
"+4922154219479" & @CRLF & _
"0214154914479" & @CRLF & _
"02141 54 91 44 79" & @CRLF & _
"01517953677" & @CRLF & _
"+491517953677" & @CRLF & _
"015777953677" & @CRLF & _
"02162 - 54 91 44 79" & @CRLF & _
"(02162) 54 91 44 79" & @CRLF & _
"saddsadasdasd" & @CRLF & _
"asdasd" & @CRLF & _
"asdasd asdasd asd" & @CRLF & _
"asdasd" & @CRLF & _
"kjn asohas asdoiasd" & @CRLF & _
"23434 234 234 23" & @CRLF & _
"323" & @CRLF & _
"23434 234----234" & @CRLF & _
"///// ----" & @CRLF & _
"// id8834 3493934 //" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)