const regex = /(((\+49\ ))|(0))\d{3,4}\ (\d{7}|\d{6}(\-\d{2})?)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(((\\+49\\ ))|(0))\\d{3,4}\\ (\\d{7}|\\d{6}(\\-\\d{2})?)', 'g')
const str = `// valid
//Landline
0221 999985
0221 999985-80
// Mobile
01578 1234567
// International
+49 221 999985
+49 221 999985-60
+49 1578 1234567
// invalid
(06442) 3933023
(02852) 5996-0
(042) 1818 87 9919
06442 / 3893023
06442 / 38 93 02 3
06442/3839023
042/ 88 17 890 0
+49 221 549144 – 79
+49 221 - 542194 79
+49 (221) - 542944 79
0 52 22 - 9 50 93 10
+49(0)121-79536 - 77
+49(0)2221-39938-113
+49 (0) 1739 906-44
+49 (173) 1799 806-44
0173173990644
+4922154219479
0214154914479
02141 54 91 44 79
01517953677
+491517953677
015777953677
02162 - 54 91 44 79
(02162) 54 91 44 79
saddsadasdasd
asdasd
asdasd asdasd asd
asdasd
kjn asohas asdoiasd
23434 234 234 23
323
23434 234----234
///// ----
// id8834 3493934 //
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);