# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(((\+49\ ))|(0))\d{3,4}\ (\d{7}|\d{6}(\-\d{2})?)"
test_str = ("// valid\n"
"//Landline\n"
"0221 999985\n"
"0221 999985-80\n"
"// Mobile\n"
"01578 1234567\n"
"// International\n"
"+49 221 999985\n"
"+49 221 999985-60\n"
"+49 1578 1234567\n\n"
"// invalid\n"
"(06442) 3933023\n"
"(02852) 5996-0\n"
"(042) 1818 87 9919\n"
"06442 / 3893023\n"
"06442 / 38 93 02 3\n"
"06442/3839023\n"
"042/ 88 17 890 0\n"
"+49 221 549144 – 79\n"
"+49 221 - 542194 79\n"
"+49 (221) - 542944 79\n"
"0 52 22 - 9 50 93 10\n"
"+49(0)121-79536 - 77\n"
"+49(0)2221-39938-113\n"
"+49 (0) 1739 906-44\n"
"+49 (173) 1799 806-44\n"
"0173173990644\n"
"+4922154219479\n"
"0214154914479\n"
"02141 54 91 44 79\n"
"01517953677\n"
"+491517953677\n"
"015777953677\n"
"02162 - 54 91 44 79\n"
"(02162) 54 91 44 79\n"
"saddsadasdasd\n"
"asdasd\n"
"asdasd asdasd asd\n"
"asdasd\n"
"kjn asohas asdoiasd\n"
"23434 234 234 23\n"
"323\n"
"23434 234----234\n"
"///// ----\n"
"// id8834 3493934 //\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.