package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(HTTP:\/\/)?([^[:space:]]+).*$`)
var str = `site.com - org name - title
site.net - other name - another title
HTTP://target.ca - ca site - ca title`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}