re = /^(HTTP:\/\/)?([^[:space:]]+).*$/m
str = 'site.com - org name - title
site.net - other name - another title
HTTP://target.ca - ca site - ca title'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end