$re = '/(^[A-z0-9-]+)\/([A-z0-9-]{1,39})/m';
$str = 'reduxj/reacteeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee
gimir/meat-page
gimir/portfolio';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);