re = /(^[A-z0-9-]+)\/([A-z0-9-]{1,39})/m
str = 'reduxj/reacteeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee
gimir/meat-page
gimir/portfolio'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end