import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)";
final String string = "Jul 10 03:25:13 proxy haproxy[928]10.175.12.13:55132 [10/Jul/2018:03:25:13.174] milano~ rest_services/hybris1 716/0/0/63/779 20037 - - ---- 8/7/1/2/0 0/0 {,208.191.22.2|116.226.216.74,} \"GET /occ/v2/milano/users/current/carts/current?lang=zh_CN HTTP/1.1\"\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}