use strict;
my $str = 'Jul 10 03:25:13 proxy haproxy[928]10.175.12.13:55132 [10/Jul/2018:03:25:13.174] milano~ rest_services/hybris1 716/0/0/63/779 20037 - - ---- 8/7/1/2/0 0/0 {,208.191.22.2|116.226.216.74,} "GET /occ/v2/milano/users/current/carts/current?lang=zh_CN HTTP/1.1"
';
my $regex = qr/(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}