// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)").unwrap();
let string = "Jul 10 03:25:13 proxy haproxy[928]10.175.12.13:55132 [10/Jul/2018:03:25:13.174] milano~ rest_services/hybris1 716/0/0/63/779 20037 - - ---- 8/7/1/2/0 0/0 {,208.191.22.2|116.226.216.74,} \"GET /occ/v2/milano/users/current/carts/current?lang=zh_CN HTTP/1.1\"
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}