$re = '/(?:\w+|\s){6}(?=moderately)/';
$str = 'this is a test of a moderately long group of words';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);