re = /(?:\w+|\s){6}(?=moderately)/
str = 'this is a test of a moderately long group of words'
# Print the match result
str.match(re) do |match|
puts match.to_s
end