re = /s(.)(.*?.?(?<!\\)(?:\\\\)*)\1(.*?.?(?<!\\)(?:\\\\)*)\1([gimsxr]*?)$/
str = 's/\\\\/b/g'
# Print the match result
str.match(re) do |match|
puts match.to_s
end