const regex = /\w+(\s\w+){4,}\d+\s+\w+\s+(?:st(?:\.|reet)?|ave(?:\.|nue)?|lane|dr(?:\.|ive)?)
/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w+(\\s\\w+){4,}\\d+\\s+\\w+\\s+(?:st(?:\\.|reet)?|ave(?:\\.|nue)?|lane|dr(?:\\.|ive)?)
', '')
const str = `38246 Luxbury dr
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}