re = /\w+(\s\w+){4,}\d+\s+\w+\s+(?:st(?:\.|reet)?|ave(?:\.|nue)?|lane|dr(?:\.|ive)?)
/
str = '38246 Luxbury dr
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end