using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(\w+)\s*\+\s*)?""((?:[^""\\]|\\.)*+)""(?:\s*\+\s*(\w+))?";
string input = @"""jsdkjfdsf"" ""sdfdskjfhk\"" ""kjshdfdsfds\\"" ""sdfdslkj"" ""\\\\""
Log.d(""Hello there "" + x + "", I see your are "" + y + "" years old!"");";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}