$re = '/(?:(\w+)\s*\+\s*)?"((?:[^"\\\\]|\\\\.)*+)"(?:\s*\+\s*(\w+))?/';
$str = '"jsdkjfdsf" "sdfdskjfhk\\"" "kjshdfdsfds\\\\" "sdfdslkj" "\\\\\\\\"
Log.d("Hello there " + x + ", I see your are " + y + " years old!");';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);