re = /(?:(\w+)\s*\+\s*)?"((?:[^"\\]|\\.)*+)"(?:\s*\+\s*(\w+))?/
str = '"jsdkjfdsf" "sdfdskjfhk\\"" "kjshdfdsfds\\\\" "sdfdslkj" "\\\\\\\\"
Log.d("Hello there " + x + ", I see your are " + y + " years old!");'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end