using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(?:[^""]*(?:""[^""]*""))*[^""]*$),";
string input = @"name1,email1,year1,""country1a,country1b"",date1,hgjgjh""hgjh,ghfhg"",hghfhg,";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}