$re = '/(?=(?:[^"]*(?:"[^"]*"))*[^"]*$),/s';
$str = 'name1,email1,year1,"country1a,country1b",date1,hgjgjh"hgjh,ghfhg",hghfhg,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);