re = /(?=(?:[^"]*(?:"[^"]*"))*[^"]*$),/
str = 'name1,email1,year1,"country1a,country1b",date1,hgjgjh"hgjh,ghfhg",hghfhg,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end