import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bcolou?r(?:[a-zA-Z’s]+)?\\b";
final String string = "Red is a color.\n"
+ "His collar is too tight or too colouuuurful.\n"
+ "These are bright colours.\n"
+ "These are bright colors.\n"
+ "Calorific is a scientific term.\n"
+ "“Your life is very colorful,” she said.\n"
+ "color (U.S. English, singular noun)\n"
+ "colour (British English, singular noun)\n"
+ "colors (U.S. English, plural noun)\n"
+ "colours (British English, plural noun)\n"
+ "color’s (U.S. English, possessive singular)\n"
+ "colour’s (British English, possessive singular)\n"
+ "colors’ (U.S. English, possessive plural)\n"
+ "colours’ (British English, possessive plural)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}