import re
regex = re.compile(r"\bcolou?r(?:[a-zA-Z’s]+)?\b", flags=re.MULTILINE)
test_str = ("Red is a color.\n"
"His collar is too tight or too colouuuurful.\n"
"These are bright colours.\n"
"These are bright colors.\n"
"Calorific is a scientific term.\n"
"“Your life is very colorful,” she said.\n"
"color (U.S. English, singular noun)\n"
"colour (British English, singular noun)\n"
"colors (U.S. English, plural noun)\n"
"colours (British English, plural noun)\n"
"color’s (U.S. English, possessive singular)\n"
"colour’s (British English, possessive singular)\n"
"colors’ (U.S. English, possessive plural)\n"
"colours’ (British English, possessive plural)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")